Performance Issues

Incident Report for Value Builder

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 10:16 EDT

Monitoring

The system seems to be working normally, monitoring the situation
Posted Oct 17, 2025 - 09:03 EDT

Update

We've identified the root cause of the issue and are currently working on a solution
Posted Oct 16, 2025 - 18:14 EDT

Identified

We've identified the source of the issue as a 3rd-party library and are contacting their support team.
Posted Oct 16, 2025 - 17:54 EDT

Investigating

We have received multiple reports of users experiencing performance issues on the Value Builder Platform, which are causing pages to freeze frequently and error out. Our development team is investigating and attempting to identify the root cause.
Posted Oct 16, 2025 - 14:39 EDT
This incident affected: The Value Builder System.