Billing & Invoices unavailable

Incident Report for Value Builder

Identified

The issue has been identified and the fix will be deployed tomorrow morning.
Posted Jul 21, 2026 - 17:54 EDT

Investigating

The Billing & Invoices tab of My Profile is reporting an error. We're investigating.
Posted Jul 21, 2026 - 14:51 EDT
This incident affects: The Value Builder System.